logo Welcome, Guest. Please login or register.
March 21, 2019, 11:12:42 AM
Home Help Search Login Register
 News: Hello visitors. We are a spam free friendly lot and welcome new members. Your Vintage Outboarding is our interest. Please join us.
Spammers are Banned and Reported.

Pages: 1 2 [3]   Go Down
Print
Author Topic: mercury 650ss 1967 4 cyl  (Read 1279 times)
0 Members and 1 Guest are viewing this topic.
antman
Full Member
***
Posts: 17


View Profile
« Reply #30 on: March 11, 2019, 06:47:33 PM »

advice taken thanks mercman
new yellow leads and ,disy and plug boots  and new springy connectors should land from states in the next few days .$90 and $30 postage roughly
last  run i adjustedthe idle jet screws and idle stop on the water in gear . was idling low nicely but after sitting for an hour that setting wouldnt start very well
so i ran both screws back in and then 1 and 1/2 turns out and bang starts in a flick of the key so ill leave it at that. whilst doing so and playing and tinkering with stuff while its running under load with a friend driving ( bay was so flat ) i got a zap
off something around the dizzy- throttle linkage area .  i did run at night to check in the dark to see a short or spark leakage  but it was in drive on muffs with no load . and nothing . so hence get new leads first .. if no change then stator /alternator






Logged

it is what it is
Pages: 1 2 [3]   Go Up
Print
Jump to:  



Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Site by METRO IT